Thread (2 messages) 2 messages, 2 authors, 2010-09-23

Re: [PATCH 1/1] Rename camel case variables in channel.c

flat view

From: Joe Perches <joe@perches.com>
Date: 2010-09-23 20:41:11
Also in: lkml

On Thu, 2010-09-23 at 20:24 +0000, Haiyang Zhang wrote:
 drivers/staging/hv/channel.c |  729 +++++++++++++++++++++---------------------
[]
-	struct hv_monitor_page *monitorPage;
+	struct hv_monitor_page *monitorpage;
Some of these renames would be better with a "_" for
the CamelCase conversions (ie: CamelCase -> camel_case).

perl regex: 's/\b([A-Z])([a-z]+)([A-Z])([a-z]+)\b/\L$1$2_\L$3$4/g'

For instance, I think this should be monitor_page;
quoted hunk
-void VmbusChannelGetDebugInfo(struct vmbus_channel *Channel,
-			      struct vmbus_channel_debug_info *DebugInfo)
+void VmbusChannelGetDebugInfo(struct vmbus_channel *channel,
+			      struct vmbus_channel_debug_info *debuginfo)
perhaps debug_info
quoted hunk
 {
-	struct hv_monitor_page *monitorPage;
-	u8 monitorGroup = (u8)Channel->OfferMsg.MonitorId / 32;
-	u8 monitorOffset = (u8)Channel->OfferMsg.MonitorId % 32;
+	struct hv_monitor_page *monitorpage;
+	u8 monitorGroup = (u8)channel->OfferMsg.MonitorId / 32;
+	u8 monitorOffset = (u8)channel->OfferMsg.MonitorId % 32;
Why not convert these to monitor_(group|offset)?

etc...
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help