On Fri, 27 Oct 2006 21:33:08 -0700
Jeremy Fitzhardinge [off-list ref] wrote:
Andrew Morton wrote:
quoted
It'd be better to use include/linux/uaccess.h:probe_kernel_address() for
this operation.
Ah, yes, that was the precedent I was thinking of,
We've done open-coded __get_user() in various places in the past. The difference with
probe_kernel_address() is that it doesn't get deadlocked on mmap_sem().
but I guess it would
be better to just use it directly. It's a relatively new interface,
isn't it?
Yeah. New enough that nobody's tried using it on non-x86 ;) It needs
to do set_fs(KERNEL_DS).