On Wed 2021-02-24 07:51:39, Sasha Levin wrote:
From: Jens Axboe <axboe@kernel.dk>
[ Upstream commit e36cffed20a324e116f329a94061ae30dd26fb51 ]
Most callers check for non-zero return, and assume it's -ECHILD (which
it always will be). One caller uses the actual error return. Clean this
up and make it fully consistent, by having unlazy_walk() return a bool
instead. Rename it to try_to_unlazy() and return true on success, and
failure on error. That's easier to read.
No functional changes in this patch.
Easier to read, but not fixing bug. I don't believe this is suitable
for stable.
Best regards,
Pavel
--
http://www.livejournal.com/~pavelmachek