Re: [Cluster-devel] [PATCH] gfs2: Fix loop in gfs2_rbm_find (2)
From: Bob Peterson <hidden>
Date: 2019-01-30 20:39:38
----- Original Message -----
Hi,
[This is an automated email]
This commit has been processed because it contains a "Fixes:" tag,
fixing commit: 2d29f6b96d8f gfs2: Fix loop in gfs2_rbm_find.
The bot has tested the following trees: v4.20.5, v4.19.18, v4.14.96,
v4.9.153, v4.4.172, v3.18.133.
v4.20.5: Build OK!
v4.19.18: Failed to apply! Possible dependencies:
281b4952d185 ("gfs2: Rename bitmap.bi_{len => bytes}")
e54c78a27fcd ("gfs2: Use fs_* functions instead of pr_* function where we
can")
v4.14.96: Failed to apply! Possible dependencies:
281b4952d185 ("gfs2: Rename bitmap.bi_{len => bytes}")
dc8fbb03dcd6 ("GFS2: gfs2_free_extlen can return an extent that is too
long")
e54c78a27fcd ("gfs2: Use fs_* functions instead of pr_* function where we
can")
v4.9.153: Failed to apply! Possible dependencies:
0d1c7ae9d849 ("GFS2: Prevent BUG from occurring when normal Withdraws
occur")
281b4952d185 ("gfs2: Rename bitmap.bi_{len => bytes}")
9862ca056e65 ("GFS2: Switch tr_touched to flag in transaction")
dc8fbb03dcd6 ("GFS2: gfs2_free_extlen can return an extent that is too
long")
e54c78a27fcd ("gfs2: Use fs_* functions instead of pr_* function where we
can")
ed17545d01e4 ("GFS2: Allow glocks to be unlocked after withdraw")
v4.4.172: Failed to apply! Possible dependencies:
0d1c7ae9d849 ("GFS2: Prevent BUG from occurring when normal Withdraws
occur")
281b4952d185 ("gfs2: Rename bitmap.bi_{len => bytes}")
3e11e5304150 ("GFS2: ignore unlock failures after withdraw")
471f3db2786b ("gfs2: change gfs2 readdir cookie")
9862ca056e65 ("GFS2: Switch tr_touched to flag in transaction")
dc8fbb03dcd6 ("GFS2: gfs2_free_extlen can return an extent that is too
long")
e54c78a27fcd ("gfs2: Use fs_* functions instead of pr_* function where we
can")
ed17545d01e4 ("GFS2: Allow glocks to be unlocked after withdraw")
v3.18.133: Failed to apply! Possible dependencies:
0d1c7ae9d849 ("GFS2: Prevent BUG from occurring when normal Withdraws
occur")
281b4952d185 ("gfs2: Rename bitmap.bi_{len => bytes}")
2e60d7683c8d ("GFS2: update freeze code to use freeze/thaw_super on all
nodes")
3cdcf63ed2d1 ("GFS2: use kvfree() instead of open-coding it")
3e11e5304150 ("GFS2: ignore unlock failures after withdraw")
471f3db2786b ("gfs2: change gfs2 readdir cookie")
9862ca056e65 ("GFS2: Switch tr_touched to flag in transaction")
a3e3213676d8 ("gfs2: fix shadow warning in gfs2_rbm_find()")
dc8fbb03dcd6 ("GFS2: gfs2_free_extlen can return an extent that is too
long")
e54c78a27fcd ("gfs2: Use fs_* functions instead of pr_* function where we
can")
ed17545d01e4 ("GFS2: Allow glocks to be unlocked after withdraw")
How should we proceed with this patch?
--
Thanks,
SashaHi Sasha, We have found problems with the "gfs2: Fix loop in gfs2_rbm_find (2)" patch, so for now we would like to revert the patch it's trying to fix, which is "gfs2: Fix loop in gfs2_rbm_find" (the original). Andreas Gruenbacher just sent a revert request for the broken patch to Linus, so we should just delete "gfs2: Fix loop in gfs2_rbm_find (2)" until we can get a proper replacement and test it thoroughly. Regards, Bob Peterson