Thread (29 messages) flat view 29 messages, 9 authors, 1d ago

Re: [PATCH 01/13 net-next] net: ipv4: introduce CONFIG_IPV4 to decouple the IPv4 stack

From: "Arnd Bergmann" <arnd@arndb.de>
Date: 2026-09-10 15:37:29
Also in: batman, bridge, intel-wired-lan, linux-fsdevel, linux-nfs, linux-nvme, linux-rdma, linux-s390, linux-scsi, linux-sctp, linux-security-module, linux-wireless, lkml, lvs-devel, mptcp, netfilter-devel, target-devel

On Thu, Sep 10, 2026, at 17:11, Nicolai Buchwitz wrote:
quoted
diff --git a/net/packet/Kconfig b/net/packet/Kconfig
index 2997382d597c..00fda9e08cb0 100644
--- a/net/packet/Kconfig
+++ b/net/packet/Kconfig
@@ -5,6 +5,7 @@

 config PACKET
 	tristate "Packet socket"
+	depends on IPV4
   depends on IPV4 || !INET

Otherwise this would break existing configs with INET=n. The same 
applies to other affected options that currently permit INET=n.
Since that's a lot of symbols that all need the same dependency,
maybe we could have an intermediate symbol for it:

config IPV4_IF_INET # or any better name you can think of
      def_bool IPV4 || !INET

Similarly, everything that currently has 'depends on INET && IPV4'
could be simplified to just 'depends on IPV4', and the leftover
'depends on INET && IPV6' from the days of modular IPV6 can now
become 'depends on IPV4'. We only needed to list both in the past
to deal with the IPV6=m case.

       Arnd
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help