Re: [PATCH net-next v5 0/9] net: dsa: mt7530: modernise register access and add two DSA ops
From: patchwork-bot+netdevbpf@kernel.org
Date: 2026-09-03 02:21:40
Also in:
linux-arm-kernel, linux-mediatek, lkml
Hello: This series was applied to netdev/net-next.git (main) by Jakub Kicinski [off-list ref]: On Mon, 31 Aug 2026 16:37:43 +0100 you wrote:
The mt7530 driver carries its own register accessors that predate the regmap conversion and now largely duplicate what regmap already provides, including locking. Most of this series removes that layer. It first moves the MDIO bus locking into the switch regmap via .lock/.unlock callbacks, matching the PCS regmaps, so any path reaching the regmap is serialised automatically. With the wrappers no longer adding locking, the thin mt7530_mii_* indirection is folded away and the remaining accessors are replaced mechanically with the plain regmap API, using the coccinelle semantic patches included in the commit messages. The two remaining reset polls are converted to regmap_read_poll_timeout() and the then-unused dummy poll machinery is dropped. Open-coded register fields are converted to FIELD_GET/FIELD_PREP. None of this is intended to change behaviour. [...]
Here is the summary with links:
- [net-next,v5,1/9] net: dsa: mt7530: move MDIO bus locking into regmap
https://git.kernel.org/netdev/net-next/c/fbf5096f540d
- [net-next,v5,2/9] net: dsa: mt7530: fold mt7530_mii_write/read into mt7530_write/read
https://git.kernel.org/netdev/net-next/c/b62351d125ad
- [net-next,v5,3/9] net: dsa: mt7530: replace mt7530_write with regmap_write
https://git.kernel.org/netdev/net-next/c/63ba2b758938
- [net-next,v5,4/9] net: dsa: mt7530: replace mt7530_rmw/set/clear with regmap API
https://git.kernel.org/netdev/net-next/c/f6692ee8def4
- [net-next,v5,5/9] net: dsa: mt7530: replace mt7530_read with regmap_read
https://git.kernel.org/netdev/net-next/c/10d9d8328e8a
- [net-next,v5,6/9] net: dsa: mt7530: drop the dummy poll machinery
https://git.kernel.org/netdev/net-next/c/d7110c1dab44
- [net-next,v5,7/9] net: dsa: mt7530: convert to use field accessor macros
https://git.kernel.org/netdev/net-next/c/3d8ca6f90475
- [net-next,v5,8/9] net: dsa: mt7530: implement port_fast_age
https://git.kernel.org/netdev/net-next/c/e1d532b6b056
- [net-next,v5,9/9] net: dsa: mt7530: implement port_change_conduit op
https://git.kernel.org/netdev/net-next/c/e5ed29f15603
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html