Thread (28 messages) flat view 28 messages, 3 authors, 18d ago

Re: [PATCH net-next 05/15] batman-adv: use more descriptive var names for is_similar_or_better

From: Sven Eckelmann <sven@narfation.org>
Date: 2026-09-01 17:20:43
Also in: batman

https://netdev-ai.bots.linux.dev/sashiko/#/patchset/20260831135117.574836-1-sw%40simonwunderlich.de?part=5
quoted
diff --git a/net/batman-adv/bat_iv_ogm.c b/net/batman-adv/bat_iv_ogm.c
index 53fbdbbe8f4f..3fe09b4c3046 100644
--- a/net/batman-adv/bat_iv_ogm.c
+++ b/net/batman-adv/bat_iv_ogm.c
@@ -2424,25 +2424,26 @@ static int batadv_iv_ogm_neigh_cmp(struct batadv_neigh_node *neigh1,
 /**
  * batadv_iv_ogm_neigh_is_sob() - check if neigh1 is similarly good or better
  *  than neigh2 from the metric prospective
                ^^^^^^          ^^^^^^

Discovered by: gpt-5-6-sol, opus-5 · Missed by: sashiko-gemini
This isn't a bug, but was the summary line of the kernel-doc for
batadv_iv_ogm_neigh_is_sob() meant to be converted too?
Good point, prepared a follow up patch.
https://patch.msgid.link/20260901-bat_iv-sob-kdoc-v1-1-54be2f58b715@narfation.org

Regards,
	Sven

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help