Re: [PATCH net-next v2] selftests: net: move log_test to lib file and remove duplicate code
From: Hangbin Liu <hidden>
Date: 2026-09-01 06:26:34
Also in:
linux-kselftest, lkml
On Mon, Aug 31, 2026 at 08:03:21AM -0700, Jakub Kicinski wrote:
On Mon, 31 Aug 2026 17:21:28 +0800 Hangbin Liu wrote:quoted
Many test scripts under tools/testing/selftests/net/ each define their own log_test() function with near-identical logic for comparing a return code against an expected value and printing OK/FAIL. Add a shared log_test_expected() to lib.sh and replace each local definition with a thin wrapper that delegates to it. The function is named log_test_expected() rather than log_test() because lib.sh already exports log_test() with a different signature used by the forwarding tests. Two tests required special handling: - icmp_redirect.sh passed a fourth "xfail" argument to log_test(). The underlying issue has been fixed and the argument is always absent now, so it is simply dropped. - fib_nexthops.sh checked for ksft_skip (exit code 4) inside log_test(), but no test in the file produces that code. The check is removed, callers that need to report a skip should use log_test_skip() instead. Two callers compared against exit code 2 are left as-is since code 2 correctly counts as a failure in the previous log_test().still breaks fib_tests.sh
Oh... This patch touches too much tests. I only fixed the [ "$VERBOSE" = "1" ] checking and return 1 issue in test_bridge_neigh_suppress.sh. I didn't notice one of fib_test.sh "set -e" and also breaks here. I think there is no test would expect return 1 for log_test. So I will fix it by return 0 in the lib function directly. Thanks Hangbin