Thread (3 messages) flat view 3 messages, 3 authors, 3d ago

Re: [PATCH net v2] batman-adv: reject unrepresentable multicast TVLV offsets

From: Jakub Kicinski <kuba@kernel.org>
Date: 2026-08-11 21:57:23
Also in: batman, lkml, stable

On Mon, 10 Aug 2026 14:57:51 +0000 David Lee wrote:
+	long transport_offset = skb->data - skb->head + offset;
+
+	if (unlikely(transport_offset !=
+		     (typeof(skb->transport_header))transport_offset))
+		return false;
+
+	if (unlikely(transport_offset ==
+		     (typeof(skb->transport_header))~0U))
+		return false;
+
+	skb->transport_header = transport_offset;
+	return true;
Find a better name for the variable instead of wrapping the lines.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help