Thread (13 messages) flat view 13 messages, 5 authors, 2026-07-31

RE: [RESEND PATCH 0/6] Remove support for Windows Server 2012/2012R2 & Win8/Win8.1 versions of Hyper-V

From: Michael Kelley <hidden>
Date: 2026-07-31 03:13:29
Also in: dri-devel, linux-hyperv, linux-scsi, lkml, virtualization

From: Dave Hansen <redacted> Sent: Thursday, July 30, 2026 3:46 PM
On 7/30/26 13:11, Michael Kelley wrote:
quoted
Linux code for running as a Hyper-V guest includes special cases for
running on Hyper-V in WS2012/2012R2 and Windows 8/8.1. These versions
were initially released 14 years ago, and official support ended in 2023
(unless a customer has contracted for extended security updates).
If we had a time machine, it would be nice to go back to 2023, stick
some warnings in about this, and see if anyone screams. Could we add
some warnings the next time a Hyper-V host ends support, please?
Yes, that's a good idea. The next such milestone is Jan 12, 2027 when
Windows Server 2016 support ends. I'll see about getting such a
warning included in Linux 7.4 or 7.5.
Also, what will an end user actually see if they boot a kernel with this
series applied on one of those hypervisors? Will it just not boot? Will
it run slowly?
The VM will fail to boot, with some error messages along the way.
See my response to Hamza Mahfooz. I'll update the VMBus error
message to be more explicit about an old version of Hyper-V as a
potential cause.

Michael
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help