RE: [PATCH net-next] selftests/xsk: decouple xskxceiver and xdp apps from test_progs objects
From: Vyavahare, Tushar <hidden>
Date: 2026-07-28 05:59:36
Also in:
bpf
-----Original Message----- From: Andrii Nakryiko <redacted> Sent: Tuesday, July 28, 2026 4:05 AM To: Vyavahare, Tushar <redacted> Cc: netdev@vger.kernel.org; Karlsson, Magnus [off-list ref]; Fijalkowski, Maciej [off-list ref]; stfomichev@gmail.com; kernelxing@tencent.com; davem@davemloft.net; kuba@kernel.org; pabeni@redhat.com; ast@kernel.org; daniel@iogearbox.net; Sarkar, Tirthendu [off-list ref]; bpf@vger.kernel.org Subject: Re: [PATCH net-next] selftests/xsk: decouple xskxceiver and xdp apps from test_progs objects On Sat, Jul 18, 2026 at 6:46 AM Tushar Vyavahare [off-list ref] wrote:quoted
Build xskxceiver, xdp_hw_metadata, and xdp_features from explicit source lists instead of reusing helper objects produced by test_progs rules. Reusing shared objects such as network_helpers.o and xsk.o can pull in test_progs-only dependency chains and trigger unrelated libarena builds when invoking a single target. Keep these standalone binaries self-contained so each target builds only its own required sources and BPF skeleton dependencies. Signed-off-by: Tushar Vyavahare <redacted> --- tools/testing/selftests/bpf/Makefile | 20 +++++++++++++++----- 1 file changed, 15 insertions(+), 5 deletions(-)diff --git a/tools/testing/selftests/bpf/Makefileb/tools/testing/selftests/bpf/Makefile index b642ee489ea6..a6f0ed10ccb4 100644--- a/tools/testing/selftests/bpf/Makefile +++ b/tools/testing/selftests/bpf/Makefile@@ -934,17 +934,27 @@ $(OUTPUT)/test_verifier: test_verifier.cverifier/tests.h $(BPFOBJ) | $(OUTPUT)quoted
$(call msg,BINARY,,$@) $(Q)$(CC) $(CFLAGS) $(filter %.a %.o %.c,$^) $(LDLIBS) -o $@ -# Include find_bit.c to compile xskxceiver. -EXTRA_SRC := $(TOOLSDIR)/lib/find_bit.c prog_tests/test_xsk.c prog_tests/test_xsk.h -$(OUTPUT)/xskxceiver: $(EXTRA_SRC) xskxceiver.c xskxceiver.h $(OUTPUT)/network_helpers.o $(OUTPUT)/xsk.o $(OUTPUT)/xsk_xdp_progs.skel.h $(BPFOBJ) | $(OUTPUT) +# Keep xskxceiver independent from test_progs object dependencies. +XSKXCEIVER_SRC := xskxceiver.c xsk.c network_helpers.c \ + $(TOOLSDIR)/lib/find_bit.c prog_tests/test_xsk.c +$(OUTPUT)/xskxceiver: $(XSKXCEIVER_SRC) xskxceiver.h xsk.hnetwork_helpers.h \quoted
+ prog_tests/test_xsk.h test_progs.h bpf_util.h \ + $(OUTPUT)/xsk_xdp_progs.skel.h $(BPFOBJ) | +$(OUTPUT) $(call msg,BINARY,,$@) $(Q)$(CC) $(CFLAGS) $(filter %.a %.o %.c,$^) $(LDLIBS) -o $@ -$(OUTPUT)/xdp_hw_metadata: xdp_hw_metadata.c $(OUTPUT)/network_helpers.o $(OUTPUT)/xsk.o $(OUTPUT)/xdp_hw_metadata.skel.h | $(OUTPUT) +XDP_HW_METADATA_SRC := xdp_hw_metadata.c xsk.c network_helpers.c\quoted
+ $(TOOLSDIR)/lib/find_bit.c +$(OUTPUT)/xdp_hw_metadata: $(XDP_HW_METADATA_SRC)xdp_metadata.h \quoted
+ xsk.h network_helpers.h test_progs.h bpf_util.h \ + $(OUTPUT)/xdp_hw_metadata.skel.h $(BPFOBJ) +| $(OUTPUT) $(call msg,BINARY,,$@) $(Q)$(CC) $(CFLAGS) $(filter %.a %.o %.c,$^) $(LDLIBS) -o $@ -$(OUTPUT)/xdp_features: xdp_features.c $(OUTPUT)/network_helpers.o $(OUTPUT)/xdp_features.skel.h | $(OUTPUT) +XDP_FEATURES_SRC := xdp_features.c network_helpers.cI'm missing the point of these xxx_SRC variables, given you then go and list .h files explicitly... Just have an inline list of all the dependencies, maybe? pw-bot: cr
Good point, thanks. The *_SRC variables were only grouping .c files, but since they are single-use and the remaining dependencies still need to be listed explicitly, they don’t improve readability much. I’ve inline the dependencies directly in the rules in v2.
quoted
+$(OUTPUT)/xdp_features: $(XDP_FEATURES_SRC) xdp_features.hnetwork_helpers.h \quoted
+ test_progs.h bpf_util.h $(OUTPUT)/xdp_features.skel.h \ + $(BPFOBJ) | $(OUTPUT) $(call msg,BINARY,,$@) $(Q)$(CC) $(CFLAGS) $(filter %.a %.o %.c,$^) $(LDLIBS) -o $@ -- 2.43.0