This is an AI-generated review of your patch. The human sending this
email has considered the AI review valid, or at least plausible.
---
dt-bindings: phy: document the serdes PHY on sa8255p
This patch adds a YAML binding describing the SGMII/SerDes PHY present on
Qualcomm sa8255p platforms, where the same hardware as on sa8775p rev3 is
managed by firmware over SCMI.
quoted hunk ↗ jump to hunk
diff --git a/Documentation/devicetree/bindings/phy/qcom,sa8255p-dwmac-sgmii-phy.yaml b/Documentation/devicetree/bindings/phy/qcom,sa8255p-dwmac-sgmii-phy.yaml
new file mode 100644
index 000000000000..9e846e381555
--- /dev/null
+++ b/Documentation/devicetree/bindings/phy/qcom,sa8255p-dwmac-sgmii-phy.yaml
[ ... ]
+ power-domains:
+ maxItems: 1
+
+ power-domain-names:
+ maxItems: 1
[Low]
This isn't a bug, but would it be worth tightening the power-domain-names
schema to constrain the actual string value, along the lines of:
power-domain-names:
items:
- const: serdes
As written, only the number of entries is constrained and any arbitrary
string would pass validation, whereas the example uses "serdes":
power-domains = <&scmi7_dvfs 0>;
power-domain-names = "serdes";
Would matching the example with a const also help keep naming consistent
across DTs using this binding?
[ ... ]
--
pw-bot: cr