Thread (2 messages) read the whole thread 2 messages, 2 authors, 10d ago

Re: [PATCH net] net/mlx5e: TC, Check if flow is PEER before acquiring devcom lock

From: Jakub Kicinski <kuba@kernel.org>
Date: 2026-07-23 15:21:11
Also in: linux-rdma, lkml

This is an AI-generated review of your patch. The human sending this
email has considered the AI review valid, or at least plausible.
---
--- Patch [1]: [PATCH net] net/mlx5e: TC, Check if flow is PEER before acquiring devcom lock ---
commit 194675fd6608821b2119601ea9e7369a43686a86
Author: Shay Drory [off-list ref]

net/mlx5e: TC, Check if flow is PEER before acquiring devcom lock

This commit fixes an AA deadlock in the flow deletion path by introducing a
new PEER flag for duplicate flows on peer devices. It also claims to rename
the existing DUP flag to PRIMARY to clarify the distinction between the
original flow and its peers.
In addition, rename the existing DUP flag to PRIMARY to better reflect
its semantics. The DUP flag indicated that a flow has peer flows on
other devices, but the name was not descriptive. PRIMARY clearly
indicates this is the original flow that manages peer flows.

This makes the distinction between the two flow roles explicit:
- PRIMARY: the original flow that owns and manages peer flows
- PEER: the duplicate flows created on peer devices
[Severity: Medium]
The commit message states that the DUP flag is renamed to PRIMARY, but this
rename is completely omitted from the patch.

For example, MLX5E_TC_FLOW_FLAG_DUP is still defined in the flags enum in
drivers/net/ethernet/mellanox/mlx5/core/en/tc_priv.h, and it is still set
using flow_flag_set(flow, DUP) in mlx5e_tc_add_fdb_peer_flow() inside
drivers/net/ethernet/mellanox/mlx5/core/en_tc.c.

Was this rename intended to be included in this patch, or should the commit
message be updated to remove this claim?
-- 
pw-bot: cr
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help