[PATCH iproute2-next v2 0/2] ip nexthop: support fdb destination port
From: Jack Ma <hidden>
Date: 2026-07-23 01:25:22
Kernel side (net-next), which adds NHA_DST_PORT and is the reason for this change: net: nexthop: per-nexthop UDP dst port for fdb (VXLAN) nexthops https://lore.kernel.org/netdev/20260723-b4-vxlan-fdb-port-v4-0-46e3a2dd88a3@gmail.com/ (local) Signed-off-by: Jack Ma <redacted> --- Changes in v2: - Rename NHA_FDB_PORT to NHA_DST_PORT and the "port" keyword to "dst_port", tracking the kernel rename (generic name, still fdb-only validated). - Split the uapi header sync into its own patch (Ido Schimmel). - Add the ip-nexthop(8) man page entry for dst_port (Ido Schimmel). - Drop "fdb" from the "dst_port" usage; the kernel enforces the pairing (Ido Schimmel). - Print the dumped port as "dst_port %u " and add the missing trailing space to "fdb" (Ido Schimmel). - Link to v1: https://lore.kernel.org/netdev/20260722-b4-vxlan-fdb-port-iproute2-v1-1-45199b1ee240@gmail.com/ (local) --- Jack Ma (2): uapi: add NHA_DST_PORT ip nexthop: support fdb destination port include/uapi/linux/nexthop.h | 3 +++ ip/ipnexthop.c | 18 ++++++++++++++++-- ip/nh_common.h | 1 + man/man8/ip-nexthop.8 | 15 ++++++++++++++- 4 files changed, 34 insertions(+), 3 deletions(-) --- base-commit: 35a237091c24858cac6c6679175bb6a628cbe400 change-id: 20260722-b4-vxlan-fdb-port-iproute2-13165877ba46 Best regards, -- Jack Ma [off-list ref]