Thread (2 messages) 2 messages, 2 authors, 1d ago

Re: [PATCH nf-next] ipvs: use type-safe allocation helpers in ip_vs_rht_alloc

From: Phil Sutter <phil@nwl.cc>
Date: 2026-07-17 10:39:20
Also in: lkml, lvs-devel, netfilter-devel

On Thu, Jul 16, 2026 at 07:37:10PM +0530, Subasri S wrote:
As per Documentation/process/deprecated.rst, open-coded kmalloc
assignments for struct objects are deprecated. Replace
kzalloc(sizeof(*ptr), GFP_KERNEL) with kzalloc_obj() and
kvmalloc_array(n, sizeof(*ptr), GFP_KERNEL) with kvmalloc_objs()
in ip_vs_rht_alloc().

Compile tested with CONFIG_IP_VS=y and runtime tested using
tools/testing/selftests/net/netfilter/ipvs.sh on x86_64/QEMU.

Signed-off-by: Subasri S <redacted>
Reviewed-by: Phil Sutter <phil@nwl.cc>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help