Thread (18 messages) 18 messages, 2 authors, 1d ago

Re: [PATCH v2 net-next 06/14] net: enetc: simplify enetc4_set_port_speed()

From: Maxime Chevallier <maxime.chevallier@bootlin.com>
Date: 2026-07-02 17:32:43
Also in: imx, linux-arm-kernel, linuxppc-dev, lkml


On 7/2/26 04:57, wei.fang@oss.nxp.com wrote:
From: Wei Fang <wei.fang@nxp.com>

Since phylink only passes valid speed values to mac_link_up, the switch
statement with its default fallback to SPEED_10 is unnecessary. Replace
it with a direct call to PCR_PSPEED_VAL(). Also update PCR_PSPEED_VAL()
to use FIELD_PREP() for proper field masking instead of an open-coded
shift.

Signed-off-by: Wei Fang <wei.fang@nxp.com>
Reviewed-by: Maxime Chevallier <maxime.chevallier@bootlin.com>

Maxime
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help