Thread (4 messages) 4 messages, 2 authors, 17d ago

Re: [PATCH RESEND net-next] net: airoha: Make use of the helper function dev_err_probe()

From: Lorenzo Bianconi <lorenzo@kernel.org>
Date: 2026-07-01 08:17:14

At 2026-06-30 18:38:38, "Lorenzo Bianconi" [off-list ref] wrote:
quoted
quoted
From: Lei Zhu <redacted>

Use dev_err_probe() to reduce code size and simplify the code.

Signed-off-by: Lei Zhu <redacted>
---
The last submission was when net-next is closed.Resending it.

 drivers/net/ethernet/airoha/airoha_eth.c | 21 +++++++++------------
 1 file changed, 9 insertions(+), 12 deletions(-)
diff --git a/drivers/net/ethernet/airoha/airoha_eth.c b/drivers/net/ethernet/airoha/airoha_eth.c
index 31cdb11cd78d..189f64e83a46 100644
--- a/drivers/net/ethernet/airoha/airoha_eth.c
+++ b/drivers/net/ethernet/airoha/airoha_eth.c
@@ -3071,10 +3071,9 @@ static int airoha_probe(struct platform_device *pdev)
 	eth->dev = &pdev->dev;
 
 	err = dma_set_mask_and_coherent(eth->dev, DMA_BIT_MASK(32));
I do not think dma_set_mask_and_coherent() can return -EPROBE_DEFER, so there
is no point adding dev_err_probe() here.

Regards,
Lorenzo
Hi Lorenzo,

Thanks for your review.

Before making this patch, I referred to the comments of dev_err_probe:
"even if @err is known to never be -EPROBE_DEFER, the benefit compared
to a normal dev_err() is the standardized format of the error code."

In the probe function, I noticed devm_platform_ioremap_resource_byname
already uses dev_err_probe, while other functions still use dev_err.
Replace them with dev_err_probe for consistency, more compact error paths,
and better readability of error codes.

Best regards
Lei
I do not have a strong opinion about it, from my pov it is more clear if we use
dev_err_probe() when it really does something, but up to you.

Regards,
Lorenzo

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help