Thread (23 messages) 23 messages, 4 authors, 27d ago

Re: [PATCH 01/18] xfrm: cleanup error path in xfrm_add_policy()

From: patchwork-bot+netdevbpf@kernel.org
Date: 2026-06-13 20:41:01

Hello:

This series was applied to netdev/net-next.git (main)
by Steffen Klassert [off-list ref]:

On Fri, 12 Jun 2026 09:46:17 +0200 you wrote:
From: Deepanshu Kartikey <redacted>

Replace the open-coded manual cleanup in the error path of
xfrm_add_policy() with xfrm_policy_destroy(), which already
handles all the necessary cleanup internally. This is consistent
with how xfrm_policy_construct() handles its own error paths.

[...]
Here is the summary with links:
  - [01/18] xfrm: cleanup error path in xfrm_add_policy()
    https://git.kernel.org/netdev/net-next/c/a77d172177f3
  - [02/18] xfrm: Reject excessive values for XFRMA_TFCPAD
    https://git.kernel.org/netdev/net-next/c/41c4d3b26f5e
  - [03/18] xfrm: remove redundant assignments
    https://git.kernel.org/netdev/net-next/c/440bf355d32e
  - [04/18] xfrm: add extack to xfrm_init_state
    https://git.kernel.org/netdev/net-next/c/231a1744dc43
  - [05/18] xfrm: allow migration from UDP encapsulated to non-encapsulated ESP
    https://git.kernel.org/netdev/net-next/c/b8addb8884f2
  - [06/18] xfrm: fix NAT-related field inheritance in SA migration
    https://git.kernel.org/netdev/net-next/c/364e165e0b63
  - [07/18] xfrm: rename reqid in xfrm_migrate
    https://git.kernel.org/netdev/net-next/c/e2e92714d081
  - [08/18] xfrm: split xfrm_state_migrate into create and install functions
    https://git.kernel.org/netdev/net-next/c/8de53883a4bf
  - [09/18] xfrm: check family before comparing addresses in migrate
    https://git.kernel.org/netdev/net-next/c/b2cb192b95e5
  - [10/18] xfrm: add state synchronization after migration
    https://git.kernel.org/netdev/net-next/c/bac7a60e2678
  - [11/18] xfrm: add error messages to state migration
    https://git.kernel.org/netdev/net-next/c/15e5d32de6bf
  - [12/18] xfrm: move encap and xuo into struct xfrm_migrate
    https://git.kernel.org/netdev/net-next/c/1d97daee3038
  - [13/18] xfrm: refactor XFRMA_MTIMER_THRESH validation into a helper
    https://git.kernel.org/netdev/net-next/c/92550d30c69b
  - [14/18] xfrm: extract address family and selector validation helpers
    https://git.kernel.org/netdev/net-next/c/38d400e5d0fd
  - [15/18] xfrm: make xfrm_dev_state_add xuo parameter const
    https://git.kernel.org/netdev/net-next/c/8eed5ba25734
  - [16/18] xfrm: add XFRM_MSG_MIGRATE_STATE for single SA migration
    https://git.kernel.org/netdev/net-next/c/a9d155ea9b44
  - [17/18] xfrm: restrict netlink attributes for XFRM_MSG_MIGRATE_STATE
    https://git.kernel.org/netdev/net-next/c/c4460171d78a
  - [18/18] xfrm: add documentation for XFRM_MSG_MIGRATE_STATE
    https://git.kernel.org/netdev/net-next/c/c13c0cc6f52e

You are awesome, thank you!
-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help