Thread (7 messages) 7 messages, 2 authors, 2026-03-01

Re: [PATCH net-next v5 0/5] net: sched: refactor qdisc drop reasons into dedicated tracepoint

From: patchwork-bot+netdevbpf@kernel.org
Date: 2026-03-01 00:00:09
Also in: bpf

Hello:

This series was applied to netdev/net-next.git (main)
by Jakub Kicinski [off-list ref]:

On Thu, 26 Feb 2026 14:44:06 +0100 you wrote:
This series refactors qdisc drop reason handling by introducing a dedicated
enum qdisc_drop_reason and trace_qdisc_drop tracepoint, providing qdisc
layer drop diagnostics with direct qdisc context visibility.

Background:
-----------
Identifying which qdisc dropped a packet via skb_drop_reason is difficult.
Normally, the kfree_skb tracepoint caller "location" hints at the dropping
code, but qdisc drops happen at a central point (__dev_queue_xmit), making
this unusable. As a workaround, commits 5765c7f6e317 ("net_sched: sch_fq:
add three drop_reason") and a42d71e322a8 ("net_sched: sch_cake: Add drop
reasons") encoded qdisc names directly in the drop reason enums.

[...]
Here is the summary with links:
  - [net-next,v5,1/5] net: sched: introduce qdisc-specific drop reason tracing
    https://git.kernel.org/netdev/net-next/c/ff2998f29f39
  - [net-next,v5,2/5] net: sched: sfq: convert to qdisc drop reasons
    https://git.kernel.org/netdev/net-next/c/3e28f8ad478f
  - [net-next,v5,3/5] net: sched: rename QDISC_DROP_FQ_* to generic names
    https://git.kernel.org/netdev/net-next/c/f30d9073ec19
  - [net-next,v5,4/5] net: sched: rename QDISC_DROP_CAKE_FLOOD to QDISC_DROP_FLOOD_PROTECTION
    https://git.kernel.org/netdev/net-next/c/9d3e7f971898
  - [net-next,v5,5/5] net: sched: sch_dualpi2: use qdisc_dequeue_drop() for dequeue drops
    https://git.kernel.org/netdev/net-next/c/67713dff6398

You are awesome, thank you!
-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help