Re: [PATCH net-next] net: use ktime_t in struct scm_timestamping_internal From: Eric Dumazet <edumazet@google.com> Date: 2026-03-05 02:56:18 On Wed, Mar 4, 2026 at 8:12 AM Jason Xing [off-list ref] wrote: On Wed, Mar 4, 2026 at 9:30 AM Eric Dumazet [off-list ref] wrote:quoted - if (has_timestamping) { - tss->ts[1] = (struct timespec64) {0}; + if (tss->ts[0] | tss->ts[2]) { Maybe use tss->ts[0] || tss->ts[2]? It's a bit weird to use a single | as to readability. This was done on purpose. Code is more efficient, with a single conditional. Thanks.
Keyboard shortcuts hback out one level jnext message in thread kprevious message in thread ldrill in Escclose help / fold thread tree ?toggle this help