Re: [PATCH net-next] net: usb: sr9700: replace magic numbers with register bit macros
From: Peter Korsgaard <peter@korsgaard.com>
Date: 2026-01-24 10:25:46
Also in:
linux-usb
From: Peter Korsgaard <peter@korsgaard.com>
Date: 2026-01-24 10:25:46
Also in:
linux-usb
quoted
quoted
quoted
quoted
"Ethan" == Ethan Nelson-Moore [off-list ref] writes:
> The first byte of the Rx frame is a copy of the Rx status register, so > 0x40 corresponds to RSR_MF (meaning the frame is multicast). Replace > 0x40 with RSR_MF for clarity. (All other bits of the RSR indicate > errors. The fact that the driver ignores these errors will be fixed by > a later patch.) > The first byte of the status URB is a copy of the NSR, so 0x40 > corresponds to NSR_LINKST. Replace 0x40 with NSR_LINKST for clarity. > Signed-off-by: Ethan Nelson-Moore [off-list ref] I don't know the device, but sounds sensible. Reviewed-by: Peter Korsgaard <peter@korsgaard.com> -- Bye, Peter Korsgaard