Thread (2 messages) flat view 2 messages, 2 authors, 2026-01-24

Re: [PATCH net-next v2 1/3] net: phy: air_en8811h: factor out shareable code

From: Bjørn Mork <bjorn@mork.no>
Date: 2026-01-24 16:55:35
Also in: lkml

Andrew Lunn [off-list ref] writes:
quoted
-static int en8811h_read_status(struct phy_device *phydev)
+static int en8811h_get_lpa(struct phy_device *phydev)
 {
-	struct en8811h_priv *priv = phydev->priv;
-	u32 pbus_value;
-	int ret, val;
+	int ret;
 
 	ret = genphy_update_link(phydev);
 	if (ret)
This call to genphy_update_link() means this function is doing more
than en8811h_get_lpa() would imply.

It is hard to see from just the patch, but it also seems to set the
state in phydev back to unknown defaults, and read the master/slave
status?

So i think it needs a better name.
Yes, that was my feeling too. Just couldn't think of any.  So I took the
lazy route.  You wouldn't happen to have a suggestion?

OK, I know it's my job.  I'll try to come up with something better.


Bjørn
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help