Hello:
This series was applied to netdev/net-next.git (main)
by Jakub Kicinski [off-list ref]:
On Sat, 25 Oct 2025 20:48:20 +0200 you wrote:
Add and use an iterator for all PHY's on a MII bus, and phy_find_next()
as a prerequisite.
v2:
- rename iterator to mdiobus_for_each_phy
v3:
- add missing return value description for phy_find_next
[...]
Here is the summary with links:
- [v3,net-next,1/4] net: phy: add iterator mdiobus_for_each_phy
https://git.kernel.org/netdev/net-next/c/26888de97b2f
- [v3,net-next,2/4] net: fec: use new iterator mdiobus_for_each_phy
https://git.kernel.org/netdev/net-next/c/0514010d553a
- [v3,net-next,3/4] net: davinci_mdio: use new iterator mdiobus_for_each_phy
https://git.kernel.org/netdev/net-next/c/4575875065de
- [v3,net-next,4/4] net: phy: use new iterator mdiobus_for_each_phy in mdiobus_prevent_c45_scan
https://git.kernel.org/netdev/net-next/c/d4780abb8cce
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html