Thread (13 messages) 13 messages, 3 authors, 2025-10-17

Re: [PATCHv4 net-next 1/4] net: add a common function to compute features from lowers devices

From: Jiri Pirko <jiri@resnulli.us>
Date: 2025-10-16 13:25:03
Also in: bridge, linux-kselftest

Thu, Oct 16, 2025 at 02:38:15PM +0200, liuhangbin@gmail.com wrote:
On Thu, Oct 16, 2025 at 01:27:00PM +0200, Jiri Pirko wrote:
quoted
quoted
quoted
How about "master_upper"? This is already widely used to refer to
bond/team/bridge/other master soft devices.

MASTER_UPPER_DEV_VLAN_FEATURES?
I'm not sure if we should avoid using "master" now. Maybe just UPPER_DEV_VLAN_FEATURES?
Why? We have "master_upper" to point exactly at this kind of device.
I mean try not use "master/slave" words. I'm OK to use UPPER_DEV_* prefix.
If you don't want to use that, change the existing code. But when the
existing code uses that, new code should be consistent with it.

I will update the name if there is a next version.

Thanks
Hangbin
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help