Re: [PATCH net-next 0/8] netfilter: updates for net-next
From: Florian Westphal <fw@strlen.de>
Date: 2025-09-02 10:54:00
Also in:
netfilter-devel
From: Florian Westphal <fw@strlen.de>
Date: 2025-09-02 10:54:00
Also in:
netfilter-devel
Florian Westphal [off-list ref] wrote:
The following patchset contains Netfilter fixes for *net-next*:
1) prefer vmalloc_array in ebtables, from Qianfeng Rong.
2) Use csum_replace4 instead of open-coding it, from Christophe Leroy.
3+4) Get rid of GFP_ATOMIC in transaction object allocations, those
cause silly failures with large sets under memory pressure, from
myself.
5) Introduce new NFTA_DEVICE_PREFIX attribute in nftables netlink api,
re-using old NFTA_DEVICE_NAME led to confusion with different
kernel/userspace versions. This refines the wildcard interface
support added in 6.16 release. From Phil Sutter.As per discussion I'll route patch 5 via net tree instead, so: pw-bot: changes-requested A new nf-next -> net-next MR will follow.