On Sat, Aug 16, 2025 at 02:44:33PM -0700, Jay Vosburgh wrote:
quoted
diff --git a/Documentation/networking/bonding.rst b/Documentation/networking/bonding.rst
index 874d8a4681ec..151c964562db 100644
--- a/Documentation/networking/bonding.rst
+++ b/Documentation/networking/bonding.rst
@@ -250,7 +250,14 @@ ad_select
ports (slaves). Reselection occurs as described under the
"bandwidth" setting, above.
- The bandwidth and count selection policies permit failover of
+ prio or 3
+
+ The active aggregator is chosen by the highest total sum of
+ actor port priorities across its active ports. Note this
+ priority is ad_actor_port_prio, not per port prio, which is
+ used for primary reselect.
+
+ The bandwidth, count and prio selection policies permit failover of
Needing to have a caveat here makes me think we should instead
change the nomenclature. Perhaps "lacp_port_prio"? The standard hasn't
had "ad" in its name for 20-ish years, so I don't think we should use
"ad" in user facing options, and common usage these days is to just call
it "lacp."
Simiarly, I don't think we need "ad" in the option name, either;
the standard just calls it "actor_port_priority", is there a good reason
Sure, no problem on my side. I will update the option name.
Regards
Hangbin