RE: [Intel-wired-lan] [PATCH net] i40e: Prevent unwanted interface name changes
From: Loktionov, Aleksandr <hidden>
Date: 2025-08-20 15:51:58
Also in:
intel-wired-lan, lkml
quoted hunk ↗ jump to hunk
-----Original Message----- From: Intel-wired-lan <redacted> On Behalf Of Calvin Owens Sent: Wednesday, August 20, 2025 6:29 AM To: netdev@vger.kernel.org Cc: Nguyen, Anthony L <anthony.l.nguyen@intel.com>; Kitszel, Przemyslaw [off-list ref]; Andrew Lunn [off-list ref]; David S. Miller [off-list ref]; Eric Dumazet [off-list ref]; Jakub Kicinski [off-list ref]; Paolo Abeni [off-list ref]; Jagielski, Jedrzej [off-list ref]; Vecera, Ivan [off-list ref]; intel-wired-lan@lists.osuosl.org; linux-kernel@vger.kernel.org Subject: [Intel-wired-lan] [PATCH net] i40e: Prevent unwanted interface name changes The same naming regression which was reported in ixgbe and fixed in commit e67a0bc3ed4f ("ixgbe: prevent from unwanted interface name changes") still exists in i40e. Fix i40e by setting the same flag, added in commit c5ec7f49b480 ("devlink: let driver opt out of automatic phys_port_name generation"). Fixes: 9e479d64dc58 ("i40e: Add initial devlink support") Signed-off-by: Calvin Owens <redacted> --- drivers/net/ethernet/intel/i40e/i40e_devlink.c | 1 + 1 file changed, 1 insertion(+)diff --git a/drivers/net/ethernet/intel/i40e/i40e_devlink.cb/drivers/net/ethernet/intel/i40e/i40e_devlink.c index cc4e9e2addb7..40f81e798151 100644--- a/drivers/net/ethernet/intel/i40e/i40e_devlink.c +++ b/drivers/net/ethernet/intel/i40e/i40e_devlink.c@@ -212,6 +212,7 @@ int i40e_devlink_create_port(struct i40e_pf *pf) attrs.flavour = DEVLINK_PORT_FLAVOUR_PHYSICAL; attrs.phys.port_number = pf->hw.pf_id; + attrs.no_phys_port_name = 1;
1 is acceptable, but kernel style prefers true for boolean fields. Can you use 'true' instead?
i40e_devlink_set_switch_id(pf, &attrs.switch_id); devlink_port_attrs_set(&pf->devlink_port, &attrs); err = devlink_port_register(devlink, &pf->devlink_port, pf-quoted
hw.pf_id);
Thank you for the patch aligning i40e with ixgbe behavior to prevent unwanted interface renaming. This is correct and minimal. You're adding attrs.no_phys_port_name = 1; but there's no comment in the function explaining why. While not strictly required, maintainers often expect a short inline comment like: /* Prevent automatic phys_port_name generation (see ixgbe fix) */ This will help future readers understand why this flag is set, what do you think?
-- 2.47.2