Thread (15 messages) 15 messages, 6 authors, 2025-08-14

Re: [PATCH net-next 1/7] net: Add skb_dst_reset and skb_dst_restore

From: Stanislav Fomichev <hidden>
Date: 2025-08-14 15:45:44
Also in: linux-staging, lkml, netfilter-devel

On 08/13, Jakub Kicinski wrote:
On Wed, 13 Aug 2025 17:57:40 -0700 Jakub Kicinski wrote:
quoted
On Tue, 12 Aug 2025 08:52:39 -0700 Stanislav Fomichev wrote:
quoted
+/**
+ * skb_dst_reset() - return current dst_entry value and clear it
+ * @skb: buffer
+ *
+ * Resets skb dst_entry without adjusting its reference count. Useful in
+ * cases where dst_entry needs to be temporarily reset and restored.
+ * Note that the returned value cannot be used directly because it
+ * might contain SKB_DST_NOREF bit.
+ *
+ * When in doubt, prefer skb_dst_drop() over skb_dst_reset() to correctly
+ * handle dst_entry reference counting.  
thoughts on prefixing these two new helpers with __ to hint that
they are low level and best avoided?
Looking at the uses -- maybe skb_dstref_steal() or skb_steal_dstref()
would be a better name? We have skb_steal_sock() (et.al.) already,
same semantics.
Sure, will rename and address the rest of your feedback. Thanks for
the review!
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help