Re: [PATCH net-next] vsock: use sizeof(struct sockaddr_storage) instead of magic value
From: patchwork-bot+netdevbpf@kernel.org
Date: 2025-08-14 00:09:54
Also in:
lkml, virtualization
From: patchwork-bot+netdevbpf@kernel.org
Date: 2025-08-14 00:09:54
Also in:
lkml, virtualization
Hello: This patch was applied to netdev/net-next.git (main) by Jakub Kicinski [off-list ref]: On Tue, 12 Aug 2025 09:59:29 +0800 you wrote:
Previous commit 230b183921ec ("net: Use standard structures for generic
socket address structures.") use 'struct sockaddr_storage address;'
to replace 'char address[MAX_SOCK_ADDR];'.
The macro MAX_SOCK_ADDR is removed by commit 01893c82b4e6 ("net: Remove
MAX_SOCK_ADDR constant").
[...]
Here is the summary with links:
- [net-next] vsock: use sizeof(struct sockaddr_storage) instead of magic value
https://git.kernel.org/netdev/net-next/c/4d18083d6b2c
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html