Thread (1 message) 1 message, 1 author, 2025-07-02

Re: [Patch bpf-next v4 1/4] skmsg: rename sk_msg_alloc() to sk_msg_expand()

From: Jakub Sitnicki <jakub@cloudflare.com>
Date: 2025-07-02 09:24:33
Also in: bpf

On Mon, Jun 30, 2025 at 06:11 PM -07, Cong Wang wrote:
From: Cong Wang <redacted>

The name sk_msg_alloc is misleading, that function does not allocate
sk_msg at all, it simply refills sock page frags. Rename it to
sk_msg_expand() to better reflect what it actually does.

Reviewed-by: John Fastabend <john.fastabend@gmail.com>
Signed-off-by: Cong Wang <redacted>
---
Nit: If there happens to be another iteration, might as well add a doc
comment while at it.

Reviewed-by: Jakub Sitnicki <jakub@cloudflare.com>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help