Hi Geert,
Thanks for the patch.
On 19/06/2025 at 19:13, Geert Uytterhoeven wrote:
The rcar_canfd_f_*() inline functions to obtain channel-specific CAN-FD
register offsets really describe a memory layout. Hence replace them by
a C structure, to simplify the code, and reduce kernel size.
This also gets rid of warnings about unused rcar_canfd_f_*() inline
functions, which are reported by recent versions of clang.
Suggested-by: Vincent Mailhol <redacted>
Reported-by: Jakub Kicinski <kuba@kernel.org>
Closes: https://lore.kernel.org/20250618183827.5bebca8f@kernel.org (local)
Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>
---
Fast-tracked because of the clang warnings.
Make sense.
@Jakub, OK for me if you want to directly pick this patch without going through
the linux-can tree.
Changes compared to Vincent's original suggestion
(https://lore.kernel.org/420d37b1-5648-4209-8d6f-1ac9d780eea2@wanadoo.fr (local)):
- Move rcar_canfd_f to the old RCANFD_F_*() location,
- Update RSCFDnCFDCmXXX comment.
- Rename struct rcar_canfd_f to struct rcar_canfd_f,
^^^^^^^^^^^^
rcar_canfd_f_c ;)
- Rename cbase to fcbase,
- Drop static_assert(),
- Drop unused car_canfd_*_reg() functions.
- Drop simple wrappers around {read,write}l(),
Acked-by: Vincent Mailhol <redacted>
Yours sincerely,
Vincent Mailhol