Re: [PATCH v2] wireguard: queueing: simplify wg_cpumask_next_online()
From: Simon Horman <horms@kernel.org>
Date: 2025-06-30 16:52:48
Also in:
lkml
From: Simon Horman <horms@kernel.org>
Date: 2025-06-30 16:52:48
Also in:
lkml
On Thu, Jun 19, 2025 at 10:54:59AM -0400, Yury Norov wrote:
From: Yury Norov [NVIDIA] <yury.norov@gmail.com> wg_cpumask_choose_online() opencodes cpumask_nth(). Use it and make the function significantly simpler. While there, fix opencoded cpu_online() too. Signed-off-by: Yury Norov [NVIDIA] <yury.norov@gmail.com> --- v1: https://lore.kernel.org/all/20250604233656.41896-1-yury.norov@gmail.com/ (local) v2: - fix 'cpu' undeclared; - change subject (Jason); - keep the original function structure (Jason);
Reviewed-by: Simon Horman <horms@kernel.org>