Thread (94 messages) 94 messages, 9 authors, 2025-04-25

Re: [RFC PATCH v2 03/34] x86/msr: Rename rdpmcl() to rdpmcq()

From: Xin Li <xin@zytor.com>
Date: 2025-04-23 17:24:18
Also in: kvm, linux-acpi, linux-edac, linux-hwmon, linux-hyperv, linux-perf-users, linux-pm, lkml, platform-driver-x86, virtualization, xen-devel

On 4/23/2025 8:06 AM, Dave Hansen wrote:
On 4/23/25 07:28, Sean Christopherson wrote:
quoted
Now that rdpmc() is gone, i.e. rdpmcl/rdpmcq() is the only helper, why not simply
rename rdpmcl() => rdpmc()?  I see no point in adding a 'q' qualifier; it doesn't
disambiguate anything and IMO is pure noise.
That makes total sense to me.
Unable to argue with two maintainers on a simple naming ;), so will make
the change.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help