Thread (8 messages) 8 messages, 5 authors, 2025-05-12

Re: [PATCH v2 00/57] irqdomain: Cleanups and Documentation

From: Andy Shevchenko <hidden>
Date: 2025-03-19 10:22:31
Also in: amd-gfx, asahi, dri-devel, linux-amlogic, linux-arm-msm, linux-doc, linux-edac, linux-gpio, linux-i2c, linux-iio, linux-mediatek, linux-mips, linux-omap, linux-pci, linux-remoteproc, linux-riscv, linux-sh, linux-sound, linux-um, linux-wireless, linuxppc-dev, lkml, loongarch, platform-driver-x86

On Wed, Mar 19, 2025 at 11:30 AM Jiri Slaby (SUSE) [off-list ref] wrote:
Hi,

tl;dr if patches are agreed upon, I ask subsys maintainers to take the
respective ones via their trees (as they are split per subsys), so that
the IRQ tree can take only the rest. That would minimize churn/conflicts
during merges.

===

While I was reading through the irqdomain code and headers, I found some
naming and documentation hard to follow or incomplete. Especially the
naming of _add/_create/_instantiate functions.

I tried to come up with a better state with this patchset:
* only irq _domain_ (not host),
* only irq_domain_create*() functions, all taking fwnode uniformly,

Finally, all the irqdomain stuff is now plugged (and generated) into
Documentation. So that everyone can walk through it at
https://www.kernel.org/doc/ (once applied, of course).
I am all to support the idea, but in some cases I would think of a bit
more work to be done to get rid of the of_fwnode_handle(np) in favour
of dev_fwnode(dev). Note, this is based on a brief look, I haven't any
example at hand right now.

-- 
With Best Regards,
Andy Shevchenko
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help