Thread (6 messages) flat view 6 messages, 3 authors, 2025-03-16

Re: [PATCH v7 net-next 09/10] net: gianfar: Use device_get_child_node_count_named()

From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Date: 2025-03-13 12:35:19
Also in: linux-acpi, lkml

On Thu, Mar 13, 2025 at 09:20:10AM +0200, Matti Vaittinen wrote:
We can avoid open-coding the loop construct which counts firmware child
nodes with a specific name by using the newly added
device_get_child_node_count_named().

The gianfar driver has such open-coded loop. Replace it with the
device_get_child_node_count_named().
FWIW,
Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>

-- 
With Best Regards,
Andy Shevchenko

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help