Re: [PATCH 03/29] tty: caif: do not use N_TTY_BUF_SIZE
From: Jakub Kicinski <kuba@kernel.org>
Date: 2025-02-20 14:27:51
Also in:
linux-serial, lkml
From: Jakub Kicinski <kuba@kernel.org>
Date: 2025-02-20 14:27:51
Also in:
linux-serial, lkml
On Thu, 20 Feb 2025 12:15:40 +0100 Jiri Slaby (SUSE) wrote:
N_TTY_BUF_SIZE -- as the name suggests -- is the N_TTY's buffer size. There is no reason to couple that to caif's tty->receive_room. Use 4096 directly -- even though, it should be some sort of "SKB_MAX_ALLOC" or alike. But definitely not N_TTY_BUF_SIZE. N_TTY_BUF_SIZE is private and will be moved to n_tty.c later.
Acked-by: Jakub Kicinski <kuba@kernel.org>