Re: [PATCH 3/3] ibmvnic: Print data buffers with kernel API's
From: Jacob Keller <jacob.e.keller@intel.com>
Date: 2025-01-14 00:05:01
Also in:
lkml
On 1/13/2025 2:17 PM, Nick Child wrote:
quoted hunk ↗ jump to hunk
Previously, data buffers that were to be printed were cast to 8 byte integers and printed. This can lead to buffer overflow if the length of the buffer is not a multiple of 8. Simplify and safeguard printing by using kernel provided functions to print these data blobs. Signed-off-by: Nick Child <nnac123@linux.ibm.com> --- drivers/net/ethernet/ibm/ibmvnic.c | 23 ++++++++++++++--------- 1 file changed, 14 insertions(+), 9 deletions(-)diff --git a/drivers/net/ethernet/ibm/ibmvnic.c b/drivers/net/ethernet/ibm/ibmvnic.c index e95ae0d39948..a8f1feb9a2e7 100644 --- a/drivers/net/ethernet/ibm/ibmvnic.c +++ b/drivers/net/ethernet/ibm/ibmvnic.c@@ -5556,9 +5560,10 @@ static int handle_login_rsp(union ibmvnic_crq *login_rsp_crq, netdev->mtu = adapter->req_mtu - ETH_HLEN; netdev_dbg(adapter->netdev, "Login Response Buffer:\n"); - for (i = 0; i < (adapter->login_rsp_buf_sz - 1) / 8 + 1; i++) { - netdev_dbg(adapter->netdev, "%016lx\n", - ((unsigned long *)(adapter->login_rsp_buf))[i]); + for_each_line_in_hex_dump(i, 16, hex_str, sizeof(hex_str), 8, + adapter->login_rsp_buf, + adapter->login_rsp_buf_sz) { + netdev_dbg(adapter->netdev, "%s\n", hex_str); }
This is nicer to read and a bit more flexible than print_hex_dump. Neat.
Strictly you don't need the {} here, but i think its more readable given
all the arguments you have to pass to the for_each_macro over multiple
lines.
Reviewed-by: Jacob Keller <jacob.e.keller@intel.com>
/* Sanity checks */