Thread (20 messages) 20 messages, 3 authors, 2024-11-15

Re: [PATCH v2 01/11] PCI: Prepare removing devres from pci_intx()

From: Thomas Gleixner <hidden>
Date: 2024-11-13 16:03:50
Also in: kvm, linux-ide, linux-input, linux-pci, linux-wireless, lkml, xen-devel

On Wed, Nov 13 2024 at 13:41, Philipp Stanner wrote:
+/**
+ * pci_intx_unmanaged - enables/disables PCI INTx for device dev,
+ * unmanaged version
+ * @pdev: the PCI device to operate on
+ * @enable: boolean: whether to enable or disable PCI INTx
Except that the argument is of type int, which really should be type bool.
+ * Enables/disables PCI INTx for device @pdev
+ *
+ * This function behavios identically to pci_intx(), but is never managed with
+ * devres.
behavios?
+ */
+void pci_intx_unmanaged(struct pci_dev *pdev, int enable)
I find this function name mildy confusing. This _unmanaged suffix is not
really telling me anything. And the reference that this behaves
identically to pci_intx() makes it even worse.

This function is about controlling the PCI INTX_DISABLE bit in the
PCI_COMMAND config word, right?

So naming it pci_intx_control() would make it entirely clear what this
is about, no?

Thanks,

        tglx
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help