Thread (18 messages) 18 messages, 3 authors, 2024-10-30

Re: [PATCH RFC 02/10] net: rename skb_copy_to_page_nocache() helper

From: Alexander Duyck <hidden>
Date: 2024-10-28 17:49:51
Also in: linux-mm, lkml

On Mon, Oct 28, 2024 at 5:05 AM Yunsheng Lin [off-list ref] wrote:
Rename skb_copy_to_page_nocache() to skb_copy_to_frag_nocache()
to avoid calling virt_to_page() as we are about to pass virtual
address directly.

CC: Alexander Duyck <redacted>
CC: Andrew Morton <akpm@linux-foundation.org>
CC: Linux-MM <redacted>
Signed-off-by: Yunsheng Lin <redacted>
---
 include/net/sock.h | 9 ++++-----
 net/ipv4/tcp.c     | 7 +++----
 net/kcm/kcmsock.c  | 7 +++----
 3 files changed, 10 insertions(+), 13 deletions(-)
Looks good to me.

Reviewed-by: Alexander Duyck <alexanderduyck@fb.com>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help