Re: [PATCH v7 3/3] dt-bindings: mfd: mediatek: mt6397: Convert to DT schema format
From: Macpaul Lin <macpaul.lin@mediatek.com>
Date: 2024-10-01 07:56:51
Also in:
linux-arm-kernel, linux-devicetree, linux-input, linux-leds, linux-mediatek, linux-pm, linux-rtc, linux-sound, lkml
On 10/1/24 14:35, Krzysztof Kozlowski wrote:
External email : Please do not click links or open attachments until you have verified the sender or the content. On 01/10/2024 08:29, Krzysztof Kozlowski wrote:quoted
On Mon, Sep 30, 2024 at 03:33:11PM +0800, Macpaul Lin wrote:quoted
Convert the mfd: mediatek: mt6397 binding to DT schema format. MT6323, MT6358, and MT6397 are PMIC devices with multiple function subdevices. They share a common PMIC design but have variations in subdevice combinations. Key updates in this conversion: 1. RTC: - Convert rtc-mt6397.txt and merge into parent MT6397 PMIC DT schema. 2. Regulators: - Align to generic name "regulators". - Update references from .txt to .yaml for mt6323, mt6358, and mt6397 regulators. - Simplify regulator name labels in device tree examples. - Add a new 'mt6359-regulator' to the compatibles of regulators.Why?quoted
Merge from the other patch [1]. 3. ADC: - Add a new 'adc' property and include a $ref for sub-device node of MT6359 PMIC AUXADC: 'mediatek,mt6359-auxadc'. Merge from the other patch [1]. 4. Audio Codec: - Simplify Audio Codec part with updating compatible items. - Add 'mt6359-codec' to the compatibleWhy? .quoted
5. Clocks: - Align to generic name "clocks" for clockbuffer subdevices. 6. LEDs: - Convert leds-mt6323.txt and merge into parent MT6397 PMIC DT schema. - Update LED binding. 7. Keys: - Add detailed descriptions for power and home keys. - Add compatible: mediatek,mt6358-keys. 8. Power Controller: - Convert mt6323-poweroff.txt and merge into parent MT6397 PMIC DT schema. - Add #power-domain-cells property to fix dt-binding check error. - Clarify "BBPU" as "Baseband power up". 9. Pinctrl: - Align to generic name "pinctrl" instead of "pin-controller". 10. Compatible: - Drop "mediatek,mt6357" since there is a separated DT Schema for PMIC MT6357. 11. Examples: - MT6323: Retain complete examples for this PMIC. - MT6358 and MT6397: simplify settings in regulators. - Preserve "audio-codec", "clocks", "pinctrl", "rtc", and "keys" sections as they contain typical settings for different PMICs. Additional updates: - MAINTAINERS: Add co-maintainers and reference to mfd/mediatek,mt6397.yaml for LED and power-controller drivers. - input/mediatek,pmic-keys.yaml: Update reference to mfd/mediatek,mt6397.yaml. References: [1] https://lore.kernel.org/all/20240925171156.9115-1-macpaul.lin@mediatek.com/ (local) Signed-off-by: Sen Chu <sen.chu@mediatek.com> Signed-off-by: Macpaul Lin <macpaul.lin@mediatek.com> ---quoted
+ + adc: + type: object + $ref: /schemas/iio/adc/mediatek,mt6359-auxadc.yaml# + unevaluatedProperties: false + + audio-codec: + type: object + description: + Audio codec support with MT6358, MT6359, and MT6397. + additionalProperties: trueNo, this cannot be true. Schema is incomplete for listed compatibles.I saw now your patch for ASoC, so this is fine. All my other questions stay valid - why are you adding new devices in patch which is supposed to be ONLY conversion.
Ok, I'll drop adding new devices from other reviewed patch for this ONLY conversion.
quoted
quoted
+ + properties: + compatible: + oneOf: + - enum: + - mediatek,mt6358-sound + - mediatek,mt6359-codecThere was no such compatible. Why do you add non-existing compatibles during conversion?
Same here, will drop it in this conversion.
Best regards, Krzysztof
Thanks Macpaul Lin