Re: [PATCH net-next v7 04/25] ovpn: add basic netlink support
From: Donald Hunter <donald.hunter@gmail.com>
Date: 2024-09-26 15:06:42
From: Donald Hunter <donald.hunter@gmail.com>
Date: 2024-09-26 15:06:42
On Wed, 25 Sept 2024 at 12:36, Antonio Quartulli [off-list ref] wrote:
Donald, I see most (if not all) modules have named ops dev-del/add/get, while in ovpn I am going with new/del-dev (action and object are inverted). Do you think it'd make sense to change all the op names to follow the convention used by the other modules?
It's a good question. I'm not sure there's much consistency for either format: Total ops: 231 Starts with (new|get|del): 51 Ends with (new|get|del): 63 Exactly (new|get|del): 11 For the legacy and raw specs that I have written, I followed whatever convention was used for the enums in the UAPI, e.g. getroute from RTM_GETROUTE. The newer genetlink specs like netdev.yaml mostly favour the dev-get form so maybe that's the convention we should try to establish going forward? Cheers, Donald.