Hello Breno,
On Fri, Aug 30, 2024 at 10:12 AM Breno Leitao [off-list ref] wrote:
Hello Maksym,
On Fri, Aug 30, 2024 at 08:58:12AM -0400, Maksym Kutsevol wrote:
quoted
quoted
I am not sure this if/else/endif is the best way. I am wondering if
something like this would make the code simpler (uncompiled/untested):
quoted
Two calls in two different places to netpoll_send_udp bothers you or
the way it has to distinct cases for enabled/disabled and you prefer to
have it as added steps for the case when it's enabled?
I would say both. I try to reduce as much as possible the number of
similar calls and #else(s) is the goal.
At the same time, I admit it is easier said than done, and Jakub is
usually the one that helps me to reach the last mile.
I see, ok.
I was more looking for possible (maybe impossible) compiler
optimizations in this case.
but access to nt->np probably makes it impossible anyway, I don't know
compilers well
enough to say.
I'll make it an if then, e.g.
if (IS_ENABLED(CONFIG_NETCONSOLE_DYNAMIC)){
}