Thread (31 messages) 31 messages, 5 authors, 2024-08-06

Re: [PATCH net-next v12 04/14] mm: page_frag: add '_va' suffix to page_frag API

From: Alexander Duyck <hidden>
Date: 2024-08-01 15:22:38
Also in: bpf, intel-wired-lan, kvm, linux-mediatek, linux-mm, linux-nfs, linux-nvme, lkml, virtualization

On Thu, Aug 1, 2024 at 6:01 AM Yunsheng Lin [off-list ref] wrote:
On 2024/8/1 2:13, Alexander Duyck wrote:
quoted
On Wed, Jul 31, 2024 at 5:50 AM Yunsheng Lin [off-list ref] wrote:
quoted
Currently the page_frag API is returning 'virtual address'
or 'va' when allocing and expecting 'virtual address' or
'va' as input when freeing.

As we are about to support new use cases that the caller
need to deal with 'struct page' or need to deal with both
'va' and 'struct page'. In order to differentiate the API
handling between 'va' and 'struct page', add '_va' suffix
to the corresponding API mirroring the page_pool_alloc_va()
API of the page_pool. So that callers expecting to deal with
va, page or both va and page may call page_frag_alloc_va*,
page_frag_alloc_pg*, or page_frag_alloc* API accordingly.

CC: Alexander Duyck <redacted>
Signed-off-by: Yunsheng Lin <redacted>
Reviewed-by: Subbaraya Sundeep <sbhatta@marvell.com>
I am naking this patch. It is a pointless rename that is just going to
obfuscate the git history for these callers.
I responded to your above similar comment in v2, and then responded more
detailedly in v11, both got not direct responding, it would be good to
have more concrete feedback here instead of abstract argument.

https://lore.kernel.org/all/74e7259a-c462-e3c1-73ac-8e3f49fb80b8@huawei.com/ (local)
https://lore.kernel.org/all/11187fe4-9419-4341-97b5-6dad7583b5b6@huawei.com/ (local)
I will make this much more understandable. This patch is one of the
ones that will permanently block this set in my opinion. As such I
will never ack this patch as I see no benefit to it. Arguing with me
on this is moot as you aren't going to change my mind, and I don't
have all day to argue back and forth with you on every single patch.

As far as your API extension and naming maybe you should look like
something like bio_vec and borrow the naming from that since that is
essentially what you are passing back and forth is essentially that
instead of a page frag which is normally a virtual address.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help