Thread (43 messages) 43 messages, 10 authors, 2024-06-20

Re: [PATCH v2 2/3] mctp pcc: Allow PCC Data Type in MCTP resource.

From: Adam Young <hidden>
Date: 2024-05-30 16:25:01
Also in: lkml

On 5/28/24 23:25, Ratheesh Kannoth wrote:
On 2024-05-29 at 00:48:22, admiyo@os.amperecomputing.com (admiyo@os.amperecomputing.com) wrote:
quoted
From: Adam Young <redacted>
--- a/drivers/acpi/acpica/rsaddr.c
+++ b/drivers/acpi/acpica/rsaddr.c
@@ -282,7 +282,7 @@ acpi_rs_get_address_common(struct acpi_resource *resource,

  	/* Validate the Resource Type */

-	if ((address.resource_type > 2) && (address.resource_type < 0xC0)) {
+	if ((address.resource_type > 2) && (address.resource_type < 0xC0) && (address.resource_type != 10)) {
use macros or enums instead of hard coded numbers. That will improve code readability.
In general I agree, but this code is generated  from ACPICA and will not 
be directly commited.  The corresponding patch to acpica has already 
merged. What you see here is what the code will look like post-process 
from ACPICA conversion.

quoted
  		return (FALSE);
  	}

--
2.34.1
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help