[PATCH net 1/2] virtio_net: rename ret to err
From: Hariprasad Kelam <hkelam@marvell.com>
Date: 2024-05-28 08:31:31
Also in:
virtualization
quoted hunk ↗ jump to hunk
-----Original Message----- From: Heng Qi <redacted> Sent: Tuesday, May 28, 2024 1:22 PM To: netdev@vger.kernel.org; virtualization@lists.linux.dev Cc: Michael S. Tsirkin <mst@redhat.com>; Jason Wang [off-list ref]; Xuan Zhuo [off-list ref]; Eugenio Pérez [off-list ref]; David S. Miller [off-list ref]; Eric Dumazet [off-list ref]; Jakub Kicinski [off-list ref]; Paolo Abeni [off-list ref]; Jiri Pirko [off-list ref]; Daniel Jurgens [off-list ref] Subject: [EXTERNAL] [PATCH net 1/2] virtio_net: rename ret to err Prioritize security for external emails: Confirm sender and content safety before clicking links or opening attachments ---------------------------------------------------------------------- The integer variable 'ret', denoting the return code, is mismatched with the boolean return type of virtnet_send_command_reply(); hence, it is renamed to 'err'. The usage of 'ret' is deferred to the next patch. Signed-off-by: Heng Qi <redacted> --- drivers/net/virtio_net.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)diff --git a/drivers/net/virtio_net.c b/drivers/net/virtio_net.c index4a802c0ea2cb..6b0512a628e0 100644--- a/drivers/net/virtio_net.c +++ b/drivers/net/virtio_net.c@@ -2686,7 +2686,7 @@ static bool virtnet_send_command_reply(structvirtnet_info *vi, u8 class, u8 cmd { struct scatterlist *sgs[5], hdr, stat; u32 out_num = 0, tmp, in_num = 0; - int ret; + int err; /* Caller should know better */ BUG_ON(!virtio_has_feature(vi->vdev, VIRTIO_NET_F_CTRL_VQ));@@ -2710,10 +2710,10 @@ static bool virtnet_send_command_reply(structvirtnet_info *vi, u8 class, u8 cmd sgs[out_num + in_num++] = in; BUG_ON(out_num + in_num > ARRAY_SIZE(sgs)); - ret = virtqueue_add_sgs(vi->cvq, sgs, out_num, in_num, vi, GFP_ATOMIC); - if (ret < 0) { + err = virtqueue_add_sgs(vi->cvq, sgs, out_num, in_num, vi, GFP_ATOMIC); + if (err < 0) { dev_warn(&vi->vdev->dev, - "Failed to add sgs for command vq: %d\n.", ret); + "Failed to add sgs for command vq: %d\n.", err); mutex_unlock(&vi->cvq_lock); return false; } -- 2.32.0.3.g01195cf9f
Reviewed-by: Hariprasad Kelam <hkelam@marvell.com>