Thread (27 messages) 27 messages, 4 authors, 2023-10-15

Re: [PATCH 05/14] s390/cio: rename bitmap_size() -> idset_bitmap_size()

From: Alexander Lobakin <aleksander.lobakin@intel.com>
Date: 2023-10-11 07:30:13
Also in: dm-devel, linux-btrfs, linux-s390, lkml, ntfs3

From: Yury Norov <yury.norov@gmail.com>
Date: Mon, 9 Oct 2023 09:35:20 -0700
On Mon, Oct 09, 2023 at 05:10:17PM +0200, Alexander Lobakin wrote:
quoted
bitmap_size() is a pretty generic name and one may want to use it for
a generic bitmap API function. At the same time, its logic is not
"generic", i.e. it's not just `nbits -> size of bitmap in bytes`
converter as it would be expected from its name.
Add the prefix 'idset_' used throughout the file where the function
resides.
At the first glance, this custom implementation just duplicates the
generic one that you introduce in the following patch. If so, why
don't you switch idset to just use generic bitmap_size()?
I didn't want to introduce any semantic changes, but good point, why not.
quoted
Reviewed-by: Przemek Kitszel <przemyslaw.kitszel@intel.com>
Signed-off-by: Alexander Lobakin <aleksander.lobakin@intel.com>
[...]

Thanks,
Olek
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help