Thread (29 messages) 29 messages, 8 authors, 2023-02-13

Re: [PATCH v2 7/7] tools/testing/selftests/bpf: replace open-coded 16 with TASK_COMM_LEN

From: Yafang Shao <hidden>
Date: 2023-02-12 03:39:33
Also in: bpf, linux-fsdevel, linux-mm, linux-perf-users, lkml

On Sun, Feb 12, 2023 at 3:00 AM Steven Rostedt [off-list ref] wrote:
On Wed, 8 Feb 2023 21:33:43 -0500
Steven Rostedt [off-list ref] wrote:
quoted
OK, so it doesn't break perf, trace-cmd and rasdaemon, because the enum is
only needed in the print_fmt part. It can handle it in the field portion.

That is:


system: sched
name: sched_switch
ID: 285
format:
      field:unsigned short common_type;       offset:0;       size:2; signed:0;
      field:unsigned char common_flags;       offset:2;       size:1; signed:0;
      field:unsigned char common_preempt_count;       offset:3;       size:1; signed:0;
      field:int common_pid;   offset:4;       size:4; signed:1;

      field:char prev_comm[TASK_COMM_LEN];    offset:8;       size:16;        signed:0;
                             ^^^^^^^^^^^^^^                          ^^
                            is ignored                             is used


      field:pid_t prev_pid;   offset:24;      size:4; signed:1;
      field:int prev_prio;    offset:28;      size:4; signed:1;
      field:long prev_state;  offset:32;      size:8; signed:1;
      field:char next_comm[TASK_COMM_LEN];    offset:40;      size:16;        signed:0;
      field:pid_t next_pid;   offset:56;      size:4; signed:1;
      field:int next_prio;    offset:60;      size:4; signed:1;

print fmt: "prev_comm=%s prev_pid=%d prev_prio=%d prev_state=%s%s ==> next_comm=%s next_pid=%d next_prio=%d", REC->prev_comm, REC->prev_pid, REC->prev_prio, (REC->prev_state & ((((0x00000000 | 0x00000001 | 0x00000002 | 0x00000004 | 0x00000008 | 0x00000010 | 0x00000020 | 0x00000040) + 1) << 1) - 1)) ? __print_flags(REC->prev_state & ((((0x00000000 | 0x00000001 | 0x00000002 | 0x00000004 | 0x00000008 | 0x00000010 | 0x00000020 | 0x00000040) + 1) << 1) - 1), "|", { 0x00000001, "S" }, { 0x00000002, "D" }, { 0x00000004, "T" }, { 0x00000008, "t" }, { 0x00000010, "X" }, { 0x00000020, "Z" }, { 0x00000040, "P" }, { 0x00000080, "I" }) : "R", REC->prev_state & (((0x00000000 | 0x00000001 | 0x00000002 | 0x00000004 | 0x00000008 | 0x00000010 | 0x00000020 | 0x00000040) + 1) << 1) ? "+" : "", REC->next_comm, REC->next_pid, REC->next_prio

   ^^^^^^^

Is what requires the conversions. So I take that back. It only breaks
perfetto, and that's because it writes its own parser and doesn't use
libtraceevent.
Actually, there are cases that this needs to be a number, as b3bc8547d3be6
("tracing: Have TRACE_DEFINE_ENUM affect trace event types as well") made
it update fields as well as the printk fmt.
It seems that TRACE_DEFINE_ENUM(TASK_COMM_LEN) in the trace events
header files would be a better fix.
I think because libtraceevent noticed that it was a "char" array, it just
defaults to "size". But this does have meaning for all other types, and I
can see other parsers requiring that.

-- Steve

-- 
Regards
Yafang

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help