Re: [PATCH v4 bpf-next 00/15] bpf: net: Remove duplicated code from bpf_setsockopt()
From: patchwork-bot+netdevbpf@kernel.org
Date: 2022-08-19 00:20:30
Also in:
bpf
Hello: This series was applied to bpf/bpf-next.git (master) by Alexei Starovoitov [off-list ref]: On Tue, 16 Aug 2022 23:17:04 -0700 you wrote:
The code in bpf_setsockopt() is mostly a copy-and-paste from
the sock_setsockopt(), do_tcp_setsockopt(), do_ipv6_setsockopt(),
and do_ip_setsockopt(). As the allowed optnames in bpf_setsockopt()
grows, so are the duplicated code. The code between the copies
also slowly drifted.
This set is an effort to clean this up and reuse the existing
{sock,do_tcp,do_ipv6,do_ip}_setsockopt() as much as possible.
[...]
Here is the summary with links:
- [v4,bpf-next,01/15] net: Add sk_setsockopt() to take the sk ptr instead of the sock ptr
https://git.kernel.org/bpf/bpf-next/c/4d748f991607
- [v4,bpf-next,02/15] bpf: net: Avoid sk_setsockopt() taking sk lock when called from bpf
https://git.kernel.org/bpf/bpf-next/c/24426654ed3a
- [v4,bpf-next,03/15] bpf: net: Consider has_current_bpf_ctx() when testing capable() in sk_setsockopt()
https://git.kernel.org/bpf/bpf-next/c/e42c7beee71d
- [v4,bpf-next,04/15] bpf: net: Change do_tcp_setsockopt() to use the sockopt's lock_sock() and capable()
https://git.kernel.org/bpf/bpf-next/c/cb388e7ee3a8
- [v4,bpf-next,05/15] bpf: net: Change do_ip_setsockopt() to use the sockopt's lock_sock() and capable()
https://git.kernel.org/bpf/bpf-next/c/1df055d3c7d9
- [v4,bpf-next,06/15] bpf: net: Change do_ipv6_setsockopt() to use the sockopt's lock_sock() and capable()
https://git.kernel.org/bpf/bpf-next/c/40cd308ea57c
- [v4,bpf-next,07/15] bpf: Initialize the bpf_run_ctx in bpf_iter_run_prog()
https://git.kernel.org/bpf/bpf-next/c/2b5a2ecbfdc5
- [v4,bpf-next,08/15] bpf: Embed kernel CONFIG check into the if statement in bpf_setsockopt
https://git.kernel.org/bpf/bpf-next/c/ebf9e8e65366
- [v4,bpf-next,09/15] bpf: Change bpf_setsockopt(SOL_SOCKET) to reuse sk_setsockopt()
https://git.kernel.org/bpf/bpf-next/c/29003875bd5b
- [v4,bpf-next,10/15] bpf: Refactor bpf specific tcp optnames to a new function
https://git.kernel.org/bpf/bpf-next/c/57db31a1a3ad
- [v4,bpf-next,11/15] bpf: Change bpf_setsockopt(SOL_TCP) to reuse do_tcp_setsockopt()
https://git.kernel.org/bpf/bpf-next/c/0c751f7071ef
- [v4,bpf-next,12/15] bpf: Change bpf_setsockopt(SOL_IP) to reuse do_ip_setsockopt()
https://git.kernel.org/bpf/bpf-next/c/ee7f1e1302f5
- [v4,bpf-next,13/15] bpf: Change bpf_setsockopt(SOL_IPV6) to reuse do_ipv6_setsockopt()
https://git.kernel.org/bpf/bpf-next/c/75b64b68ee3f
- [v4,bpf-next,14/15] bpf: Add a few optnames to bpf_setsockopt
https://git.kernel.org/bpf/bpf-next/c/7e41df5dbba2
- [v4,bpf-next,15/15] selftests/bpf: bpf_setsockopt tests
https://git.kernel.org/bpf/bpf-next/c/31123c0360e0
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html