On Wed, 2022-06-08 at 16:00 -0700, Eric Dumazet wrote:
On Wed, Jun 8, 2022 at 3:58 PM David Ahern [off-list ref] wrote:
quoted
On 6/8/22 8:58 AM, Jakub Kicinski wrote:
quoted
IMO to encourage use of the track-capable API we could keep their names
short and call the legacy functions __netdev_hold() as I mentioned or
maybe netdev_hold_notrack().
I like that option. Similar to the old nla_parse functions that were
renamed with _deprecated - makes it easier to catch new uses.
I think we need to clearly document the needed conversions for future
bugfix backports.
To be on the same page: do you think we need something under
Documentation with this patch? or with the later dev_hold rename? or
did I misunderstood completely?
Thanks!
Paolo