On Fri, 25 Feb 2022 09:31:23 +0100 Petr Machata wrote:
quoted
quoted
+ struct rtnl_link_stats64 *offload_xstats_l3;
Does it make sense to stick to rtnl_link_stats64 for this?
There's a lot of.. historical baggage in that struct.
It seemed like a reasonable default that every tool already understands.
Was there a discussion in the past about what a cross-vendor stats suite
should look like? It seems like one of those things that can be bikeshed
forever...
What I meant is take out all the link-level / PHY stuff, I don't think
any HW would be reporting these above the physical port. Basically when
you look at struct rtnl_link_stats64 we can remove everything starting
from and including collisions, right?
And looking at your patch that'd leave exactly the stats you actually
use..